问题现象:
第三方应用计步和负一屏计步信息不一致或者计步没有步数。
问题原因:
1. 应用未开启运动权限导致应用无法读取手机运动步数;
2. 应用未开启自启动权限,应用不在手机后台运行导致计步不准;
3. 手机网络/定位信号较差时应用步数未更新导致计步不准;
4. 手机未随时携带行走导致三方应用计步不准。
5. 手机硬件问题导致导致计步不准。
解决方案:
应用计步不准可能有多方面的原因导致,建议您按照如下方式排查:
1. 长按第三方应用,点击应用信息/应用详情 > 权限管理,开启位置信息和健身运动权限,允许第三方读取手机健康数据;
2. 长按第三方应用,点击应用信息/应用详情 > 耗电管理,开启第三方应用允许应用自启动权限和允许完全后台行为权限;
3. 在设置 > 电池中关闭手机省电模式,省电模式下系统会减少后台应用可能导致计步不准;
4. 运动时随身携带手机,手机下拉打开通知中心开启定位服务开关;
5. 长按第三方应用,点击应用信息/应用详情 > 存储占用,清除第三方应用的缓存信息,刷新计步数据。
如上述步骤排查后依然存在此问题,请您备份好数据前往就近的realme客户服务中心检测。